[AppStore ガイドライン対訳]ガイドライン対訳 4.4.2 Safari エクステンションについて(Safari on macOS)

(この項はiOSは関係ありません)

Safari エクステンションは最新のSafariで動作する必要がある。
(訳注 最新のSafariで動かなければリジェクト)

システム(Safariやmac)のUIと干渉してはいけない。

ユーザーを機能の遂行に不必要なサイトに飛ばしたりするとリジェクト。

このルールに接触すると、デベロッパ除名する。

原文
4.4.2 Safari extensions must run on the current version of Safari on macOS.
They may not interfere with System or Safari UI elements and must never include malicious or misleading content or code.
Violating this rule will lead to removal from the Developer Program.
Safari extensions should not claim access to more websites than strictly necessary to function.

interfere v.鑑賞する
malicious a.悪意のある
Violate 妨害する
lead v.案内する、運ぶ、導く、(結果として)〜なる
lead to 結果につながる、きたす、につながる
strictly adv.厳密に、厳しく

公式翻訳
4.4.2 Safari Extensionは、macOSの最新のSafariで実行可能である必要があります。
システムまたはSafariのユーザーインターフェイスを構成する要素と相互干渉してはならず、
悪意のある、または誤解を生むコンテンツ、またはコードを使用することは許可されません。
このルールに違反すると、Developer Programから除名されることになります。
Safari Extensionを使用して、機能の動作に必要でないWebサイトにアクセスするようユーザーに要求することはできません。

Google翻訳
4.4.2 Safari拡張機能は、macOS上の現行バージョンのSafari上で実行する必要があります。システムやSafariのUI要素に干渉することはなく、悪意のあるコンテンツや誤解を招くようなコンテンツやコードは絶対に含まれてはいけません。このルールに違反すると、開発者プログラムから削除されます。Safariの拡張機能は、機能するために厳密に必要なウェブサイト以上のウェブサイトへのアクセスを要求すべきではありません。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です