[Python]You should consider upgrading via the ‘ pip install –upgrade pip’ command 特定のライブラリだけインストールできない場合の対策

python
pip 使用時に、 以下のようなメッセージが表示されてインストールが出来ないことがあります。

 

対策として、pipのバージョンアップが必要になるわけですが、更新しても解決しない場合があります。
(pipのバージョンが悪いわけではない可能性もあります。)

対策
このような場合は、pip install libname に sudo を付けて実行することをおすすめします。
sudo pip install libname
sudo pip3 install libname

 

対策
pipのバージョンアップが必要になった場合は、以下のコマンドを利用します。

pipのバージョンアップ
pipはmacの場合、pip3を使用する
pip install –upgrade pip
sudo pip install –upgrade pip
sudo -H pip install –upgrade pip

 

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です